blob: e48cc9210bb3493158a71c35d719d34ddf5f99a6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Simple program to read/write from/to any location in memory"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://devmem2.c;endline=28;md5=dd68f2b0a5184b3db3dc25c99e0bd0cd"
4PR = "r7"
5
6SRC_URI = "http://www.lartmaker.nl/lartware/port/devmem2.c \
7 file://devmem2-fixups-2.patch;apply=yes;striplevel=0"
8S = "${WORKDIR}"
9
10CFLAGS += "-DFORCE_STRICT_ALIGNMENT"
11
12do_compile() {
13 ${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS}
14}
15
16do_install() {
17 install -d ${D}${bindir}
18 install devmem2 ${D}${bindir}
19}
20
21SRC_URI[md5sum] = "be12c0132a1ae118cbf5e79d98427c1d"
22SRC_URI[sha256sum] = "ec382c90af3ef2f49695ff14a4d6521e58ac482c4e29d6c9ebca8768f699c191"