blob: 2582820e6815fe0926cfcb4aa9946a862e029102 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "read temperature sensors in a 1-Wire net"
2SECTION = "util"
3DEPENDS = "libusb1"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
6
7PR = "r2"
8
9SRC_URI = "http://www.digitemp.com/software/linux/digitemp-${PV}.tar.gz \
10 file://makefile-fix.patch"
11SRC_URI[md5sum] = "9be2e48db37920f21925ae6e88f83b84"
12SRC_URI[sha256sum] = "14cfc584cd3714fe8c9a2cdc8388be49e08b5e395d95e6bcd11d4410e2505ca2"
13
14EXTRA_OEMAKE = "ds9097 ds9097u \
15 SYSTYPE='Linux' \
16"
17# Fix GNU_HASH QA errors
18TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
19
20do_configure() {
21 rm -f digitemp_*
22}
23
24do_install() {
25 install -d ${D}${sbindir}
26 install digitemp_* ${D}${sbindir}
27}