blob: f2a225874d6b8e87aa0dda5fba201dc42f8ea194 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A PKCS"
2DESCRIPTION = "\
3Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be \
4loaded using code, config file or command line and will pass any function \
5call by openssl to a PKCS cards and software for using smart cards in PKCS"
6HOMEPAGE = "https://github.com/OpenSC/engine_pkcs11"
7SECTION = "Development/Libraries"
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://src/engine_pkcs11.h;startline=1;endline=26;md5=973a19f8a6105de047f2adfbbfc04c33"
10DEPENDS = "openssl libp11"
11
12SRC_URI = "git://github.com/OpenSC/engine_pkcs11.git;protocol=http"
13SRCREV = "6909d6761c8820e1750fa0bf4fa8532c82f34e35"
14
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "\
20 --disable-static \
21 --libdir ${libdir}/openssl \
22"
23
24do_install_append () {
25 rm -f ${D}${libdir}/openssl/engines/libpkcs11.la
26}
27
28FILES_${PN} += "${libdir}/openssl/engines/libpkcs11.so*"
29FILES_${PN}-dbg += "${libdir}/openssl/engines/.debug/*"