blob: 620ee1f6ccee037ad6cbf1c7b1548b03b5f4e500 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Interactive Connectivity Establishment library"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
4SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
5
6LICENSE = "LGPLv2.1 & MPLv1.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
8 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
9 file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
10"
11
12PR = "r4"
13
14DEPENDS = "glib-2.0 gstreamer"
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
18
19inherit autotools pkgconfig gtk-doc
20
21FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
22FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la"
23FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a"
24FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
25
26do_configure_prepend() {
27 mkdir ${S}/m4 || true
28}
29
30do_compile_append() {
31 for i in $(find ${B} -name "*.pc") ; do
32 sed -i -e s:${STAGING_DIR_TARGET}::g \
33 -e s:/${TARGET_SYS}::g \
34 $i
35 done
36}
37
38
39SRC_URI[md5sum] = "e5b9f799a57cb939ea2658ec35253ab9"
40SRC_URI[sha256sum] = "d8dd260c486a470a6052a5323920878a084e44a19df09b15728b85c9e3d6edf0"