blob: 88f7a4ff1fea8dc36ceebf46dac9ef6d72afaabe [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Default display timings and resolutions for fbset"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5PV = "0.1.0"
6PR = "r6"
7
8SRC_URI = "file://fb.modes"
9S = "${WORKDIR}"
10
11do_install() {
12 install -d ${D}${sysconfdir}
13 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
14}
15
16inherit allarch
17
18# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
19# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
20PACKAGE_ARCH = "${MACHINE_ARCH}"
21
22CONFFILES_${PN} = "${sysconfdir}/fb.modes"