blob: cbbe6caeee5e0ca9f4b93131e6cb4a710538577f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001#
2# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
3# License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license)
4#
5# Filename: fbset_2.1.bb
6# Date: 28-May-06
7
8SUMMARY = "The fbset console tool"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://fbset.c;endline=19;md5=bf326f82cdfcac391af208f019c5603f"
11RRECOMMENDS_${PN} = "fbset-modes"
12DEPENDS = "bison-native flex-native"
13
14PR = "r4"
15
16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
17 file://makefile.patch \
18 file://fbset-2.1-fix-makefile-dep.patch \
19 file://0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch \
20"
21
22inherit update-alternatives
23
24do_install() {
25 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
26 install -m 0755 ${B}/fbset ${D}${sbindir}/fbset.real
27 install -m 0644 ${B}/*.5 ${D}${datadir}/man/man5
28 install -m 0644 ${B}/*.8 ${D}${datadir}/man/man8
29}
30
31ALTERNATIVE_fbset = "fbset"
32ALTERNATIVE_LINK_NAME[fbset] = "${sbindir}/fbset"
33ALTERNATIVE_TARGET[fbset] = "${sbindir}/fbset.real"
34ALTERNATIVE_PRIORITY[fbset] = "55"
35
36SRC_URI[md5sum] = "40ed9608f46d787bfb65fd1269f7f459"
37SRC_URI[sha256sum] = "517fa062d7b2d367f931a1c6ebb2bef84907077f0ce3f0c899e34490bbea9338"