blob: d859386be88e371539392f4659df76078b4cb1ec [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "FFTW benchmarks"
2SECTION = "libs"
3LICENSE = "GPLv2"
4
5# single precision fftw is called fftwf
6DEPENDS = "virtual/fftw"
7
8SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz"
9
10EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared"
11
12inherit autotools pkgconfig
13
14do_compile_prepend() {
15 sed -i -e 's:all-recursive:$(RECURSIVE_TARGETS):g' ${S}/Makefile
16}
17
18SRC_URI[md5sum] = "9356e5e9dcb3f1481977009720a2ccf8"
19SRC_URI[sha256sum] = "1b4a5b5e48ad5e61a21586b7b59d5c0a88691a981e73e2c6dc5868197461791b"
20
21PNBLACKLIST[benchfft] ?= "does not build with distroless qemuarm as reported in 'State of bitbake world' thread, nobody volunteered to fix them"