blob: 117ecc366ab4771de896910a7bb606f722278a8d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "FLTK is a cross-platform C++ GUI toolkit"
2HOMEPAGE = "http://www.fltk.org"
3SECTION = "libs"
4LICENSE = "LGPLv2 & FLTK"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f6b26344a24a941a01a5b0826e80b5ca"
6
7DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
8
9SRC_URI = "http://fltk.org/pub/fltk/${PV}/${BP}-source.tar.gz \
10 file://disable_test.patch \
11 file://fltk-no-freetype-config.patch \
12 file://fix-boolean-issue-with-jpeg9.patch \
13"
14
15SRC_URI[md5sum] = "9ccdb0d19dc104b87179bd9fd10822e3"
16SRC_URI[sha256sum] = "f8398d98d7221d40e77bc7b19e761adaf2f1ef8bb0c30eceb7beb4f2273d0d97"
17
18inherit autotools-brokensep binconfig pkgconfig lib_package
19
20TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2"
21
22EXTRA_OECONF = "--enable-shared \
23 --enable-threads \
24 --enable-xdbe \
25 --enable-xft \
26"
27
28PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl', '', d)}"
29
30PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl"
31PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
32PACKAGECONFIG[xfixes] = "--enable-xfixes,--disable-xfixes,libxfixes"
33PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
34
35do_configure() {
36 oe_runconf
37}
38
39do_install_append_class-target() {
40 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/fltk-config
41}
42
43python populate_packages_prepend () {
44 if (d.getVar('DEBIAN_NAMES', 1)):
45 d.setVar('PKG_${BPN}', 'libfltk${PV}')
46}
47
48LEAD_SONAME = "libfltk.so"
49