blob: 85c7e6a0517d28c93de97830e00ba38de0418443 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
13DEPENDS = "freetype libpng jpeg zlib tiff"
14
15SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \
16"
17SRC_URI[md5sum] = "d3f1a992ac9c550ebc6da89c147f89af"
18SRC_URI[sha256sum] = "895ea9c6fcab187b0a908ae3e9e6b06423756f8a643d362349b0caab4014bd0d"
19
20S = "${WORKDIR}/libgd-${PV}"
21
22inherit autotools binconfig gettext pkgconfig
23
24EXTRA_OECONF += " --disable-rpath \
25 --with-jpeg=${STAGING_LIBDIR}/.. \
26 --with-freetype=yes \
27 --without-fontconfig \
28 --without-xpm \
29 --without-x \
30 --without-vpx \
31 "
32
33EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
34
35do_install_append() {
36 # cleanup buildpaths from gdlib.pc
37 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
38}
39
40PACKAGES += "${PN}-tools"
41
42FILES_${PN} = "${libdir}/lib*${SOLIBS}"
43FILES_${PN}-tools = "${bindir}/*"
44
45PROVIDES += "${PN}-tools"
46RPROVIDES_${PN}-tools = "${PN}-tools"
47RDEPENDS_${PN}-tools = "perl perl-module-strict"