blob: 7022057d4a405a3b2c96f1f3ec7947ea24a1b5ff [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
2for the console and xterm, with sample clients included \
3(emacs, etc)."
4SECTION = "console/utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://gpm2/core/main.c;endline=19;md5=66d3c205c4e7ee5704b2ee351dfed72f"
7
8PR = "r2"
9
10DEPENDS = "ncurses"
11
12SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
13 file://no-docs.patch \
14 file://processcreds.patch \
15 file://eglibc-2.17.patch \
16 file://init"
17
18inherit autotools-brokensep update-rc.d
19
20INITSCRIPT_NAME = "gpm"
21INITSCRIPT_PARAMS = "defaults"
22
23#export LIBS = "-lm"
24
25# all fields are /* FIXME: gpm 1.99.13 */
26# gpm-1.99.7/src/lib/libhigh.c:171:43: error: parameter 'clientdata' set but not used [-Werror=unused-but-set-parameter]
27# gpm-1.99.7/src/lib/report-lib.c:28:21: error: parameter 'line' set but not used [-Werror=unused-but-set-parameter]
28# gpm-1.99.7/src/lib/report-lib.c:28:33: error: parameter 'file' set but not used [-Werror=unused-but-set-parameter]
29# gpm-1.99.7/src/drivers/empty/i.c:26:23: error: parameter 'fd' set but not used [-Werror=unused-but-set-parameter]
30# gpm-1.99.7/src/drivers/empty/i.c:26:42: error: parameter 'flags' set but not used [-Werror=unused-but-set-parameter]
31# gpm-1.99.7/src/drivers/etouch/i.c:34:43: error: parameter 'flags' set but not used [-Werror=unused-but-set-parameter]
32# gpm-1.99.7/src/drivers/msc/r.c:32:12: error: variable 'dy' set but not used [-Werror=unused-but-set-variable]
33# gpm-1.99.7/src/drivers/msc/r.c:32:8: error: variable 'dx' set but not used [-Werror=unused-but-set-variable]
34# cc1: all warnings being treated as errors
35CFLAGS += "-Wno-extra -Wno-error=unused-but-set-parameter -Wno-error=unused-but-set-variable"
36
37# twiddler is WIP in 1.99.7 and probably not worth fixing (a lot of changes in gpm-2-dev after 1.99.7
38# gpm-1.99.7/src/drivers/twid/twiddler.c:503:14: error: cast to pointer from integer of different size [-Werror=int-to-pointer-cast]
39# /gpm-1.99.7/src/mice.c:221:5: error: (near initialization for 'mice[32].init') [-Werror]
40CFLAGS += "-Wno-error=int-to-pointer-cast -Wno-error"
41
42do_install () {
43 oe_runmake 'DESTDIR=${D}' install
44 install -m 0644 src/headers/gpm.h ${D}${includedir}
45 install -d ${D}/${sysconfdir}/init.d
46 install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
47 cd ${D}${libdir} && ln -sf libgpm.so.1.19.0 libgpm.so.1
48}
49SRC_URI[md5sum] = "9fdddf5f53cb11d40bb2bb671d3ac544"
50SRC_URI[sha256sum] = "6071378b24494e36ca3ef6377606e7e565040413c86704753a162d2180af32ee"
51
52FILES_${PN} += "${datadir}/emacs"