blob: a9f01344a9ff350d8de5cc4a8f555e4cf842b51a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ImageMagick is an image convertion tools"
2SECTION = "console/utils"
3LICENSE = "ImageMagick"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0887b670be7ef0c3cb37092b64d57514"
5# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
6DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib virtual/fftw freetype"
7
8# Important note: tarballs for all patchsets within a version are deleted when
9# a new pachset is created. To avoid multiple patches for each patchset, try to
10# update to the last pachset of a version
11PATCHSET = "0"
12SRC_URI = "http://www.imagemagick.org/download/releases/ImageMagick-${PV}-${PATCHSET}.tar.xz \
13"
14SRC_URI[md5sum] = "99471c8c3f38c9264faf5c4ca7a31287"
15SRC_URI[sha256sum] = "07a2de28f7f9ab888ef47c02eb7e10cc3e0dd0e9797c5d71d6e71d19f842399e"
16
17S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
18
19inherit autotools pkgconfig update-alternatives
20
21# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
22# if someone needs xml support then fix it first
23EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-perl --disable-openmp --without-xml --disable-opencl"
24
25CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
26PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
27PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
28PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
29PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
30PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
31PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
32PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
33PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
34
35FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
36 ${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \
37 ${libdir}/ImageMagick-${PV}/modules-Q16/filters \
38 ${libdir}/ImageMagick-${PV}/modules-Q16/coders \
39 ${libdir}/ImageMagick-${PV}/config-Q16 \
40 ${datadir}/ImageMagick-6 "
41
42FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a"
43
44FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*"
45
46BBCLASSEXTEND = "native"
47
48ALTERNATIVE_PRIORITY = "100"
49
50ALTERNATIVE_${PN} = "animate compare composite conjure convert display \
51 identify import mogrify montage stream"
52
53ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im6"
54ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im6"
55ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im6"
56ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im6"
57ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im6"
58ALTERNATIVE_TARGET[display] = "${bindir}/display.im6"
59ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im6"
60ALTERNATIVE_TARGET[import] = "${bindir}/import.im6"
61ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im6"
62ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im6"
63ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im6"
64
65ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
66 convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1"
67
68ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
69ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im6.1"
70ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
71ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im6.1"
72ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
73ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im6.1"
74ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
75ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im6.1"
76ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
77ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im6.1"
78ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
79ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im6.1"
80ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
81ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im6.1"
82ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
83ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im6.1"
84ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
85ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im6.1"
86ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
87ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im6.1"
88ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
89ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im6.1"