blob: 5f3b8893466e03ce58d2d26b0d5a4877d041c4f7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A graphical front-end for gcov"
2HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php"
3DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
4tool gcov. It collects gcov data for multiple source files and creates \
5HTML pages containing the source code annotated with coverage information. \
6It also adds overview pages for easy navigation within the file structure. \
7LCOV supports statement, function and branch coverage measurement."
8LICENSE = "GPL-2.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
11RDEPENDS_${PN} += " \
12 gcov \
13 perl \
14 perl-module-filehandle \
15 perl-module-getopt-std \
16 perl-module-digest-sha \
17"
18
19SRC_URI = "http://downloads.sourceforge.net/ltp/${BP}.tar.gz"
20
21SRC_URI[md5sum] = "e79b799ae3ce149aa924c7520e993024"
22SRC_URI[sha256sum] = "c282de8d678ecbfda32ce4b5c85fc02f77c2a39a062f068bd8e774d29ddc9bf8"
23
24do_install() {
25 oe_runmake install PREFIX=${D}
26 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/*
27}
28