blob: 89a25a9a35fe92a986d118f21a715f368f0658f7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms."
2AUTHOR = "Benoît Jacob and Gaël Guennebaud and others"
3HOMEPAGE = "http://eigen.tuxfamily.org/"
4LICENSE = "MPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad"
6
7SRC_URI = "http://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 \
8 file://0001-CMakeLists.txt-install-FindEigen3.cmake-script.patch"
9SRC_URI[md5sum] = "87274966745d2d3e7964fcc654d0a24b"
10SRC_URI[sha256sum] = "8a3352f9a5361fe90e451a7305fb1896fc7f771dc16cc0edd8e6b157f52c343e"
11
12S = "${WORKDIR}/eigen-eigen-c58038c56923"
13
14inherit cmake
15
16EXTRA_OECMAKE += "-Dpkg_config_libdir=${libdir}"
17
18FILES_${PN} = "${includedir} ${libdir}"
19FILES_${PN}-dev = "${datadir}/cmake/Modules"
20
21# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
22RDEPENDS_${PN}-dev = ""
23RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"