blob: a4a0f3883e967dab417200863deff16a5d08e1c4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5SECTION = "net"
6DEPENDS = "libgcrypt gnutls file"
7
8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9SRC_URI[md5sum] = "2947eee13c2c8affb95023a0cb6fda0c"
10SRC_URI[sha256sum] = "29a2bfd4fd2ddf60c756b8c283291a134898e3cc143843be421a040be1b25a88"
11
12inherit autotools lib_package
13
14# disable spdy, because it depends on openssl
15EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --disable-spdy"
16
17PACKAGECONFIG ?= "curl"
18PACKAGECONFIG_append_class-target = "\
19 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
20"
21PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
22PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
23
24do_compile_append() {
25 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
26}
27