blob: 0249abe24a9cefa92b0ee8940aa379a6b7040af0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Simple DirectMedia Layer truetype font library"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl freetype"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://COPYING;md5=22800d1b3701377aae0b61ee36f5c303"
6
7SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \
8 file://use.pkg-config.for.freetype2.patch \
9"
10SRC_URI[md5sum] = "61e29bd9da8d245bc2471d1b2ce591aa"
11SRC_URI[sha256sum] = "724cd895ecf4da319a3ef164892b72078bd92632a5d812111261cde248ebcdb7"
12
13S = "${WORKDIR}/SDL_ttf-${PV}"
14
15inherit autotools
16
17do_configure_prepend() {
18 # make autoreconf happy
19 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog
20
21 # Removing these files fixes a libtool version mismatch.
22 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
23
24 for i in ${MACROS}; do
25 rm -f ${S}/acinclude/$i
26 done
27}