blob: c43164e5d58666be94446908512769c2ed001e63 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz"
11SRC_URI[md5sum] = "00aabd6e714a5f42a4fb82ace20db1dd"
12SRC_URI[sha256sum] = "5a202943a34a1d82a1c31f74094f2453c207bf9936093867f41414968c8e8215"
13
14inherit autotools pkgconfig
15
16EXTRA_OECONF += "\
17 --with-libz \
18 --with-libz-prefix=${STAGING_LIBDIR} \
19 "
20
21# only one of openssl and gcrypt could be set
22PACKAGECONFIG ??= "openssl"
23PACKAGECONFIG[openssl] = "--with-openssl --with-libssl-prefix=${STAGING_LIBDIR},--without-openssl,openssl"
24PACKAGECONFIG[gcrypt] = "--with-libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR},--without-libgcrypt,libgcrypt"