blob: 0282ba50059120f6f1f8c6a850ef64338ddd09cc [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A privileged helper for utmp/wtmp updates"
2DESCRIPTION = "\
3This library provides interface for terminal emulators such as \
4screen and xterm to record user sessions to utmp and wtmp files."
5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
6SECTION = "System Environment/Libraries"
7LICENSE = "GPLv2 & GPLv2+ & LGPLv2 & MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
9
10SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018"
11PV = "1.1.6-alt2+git${SRCPV}"
12
13SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git \
14 file://0001-Fix-macro-error.patch"
15
16S = "${WORKDIR}/git/${BPN}"
17
18CFLAGS += "-DLIBEXECDIR=${libexecdir}"
19
20do_compile() {
21 oe_runmake \
22 libdir=${libdir} \
23 libexecdir=${libexecdir}
24}
25
26do_install() {
27 oe_runmake install \
28 DESTDIR=${D} \
29 libdir="${libdir}" \
30 libexecdir="${libexecdir}" \
31 includedir=${includedir} \
32 mandir=${mandir}
33
34 rm -f ${D}${libdir}/*.a
35}
36
37FILES_${PN} = "${libdir}/*.so.*"
38FILES_${PN} += "${libexecdir}/utempter/utempter"
39FILES_${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"