blob: 3638019c4b4d14cfbda4787f7148736e04e7d232 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "lm_sensors configuration files"
2DESCRIPTION = "Hardware health monitoring configuration files"
3HOMEPAGE = "http://www.lm-sensors.org/"
4LICENSE = "MIT-X"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9SRC_URI = "file://fancontrol \
10 file://sensord.cgi \
11 file://sensord.conf \
12 file://sensors.conf \
13 file://sensord \
14"
15S = "${WORKDIR}"
16
17RDEPENDS_${PN}-dev = ""
18
19do_install() {
20 # Install fancontrol configuration file
21 install -d ${D}${sysconfdir}/sysconfig
22 install -m 0644 ${WORKDIR}/fancontrol ${D}${sysconfdir}
23 install -m 0644 ${WORKDIR}/sensord ${D}${sysconfdir}/sysconfig
24 # Install libsensors configuration file
25 install -d ${D}${sysconfdir}/sensors.d
26 install -m 0644 ${WORKDIR}/sensors.conf ${D}${sysconfdir}/sensors.d
27
28 # Install sensord configuration file
29 install -m 0644 ${WORKDIR}/sensord.conf ${D}${sysconfdir}
30
31 # Install sensord.cgi script and create world-writable
32 # web-accessible sensord directory
33 install -d ${D}/www/pages/cgi-bin
34 install -m 0755 ${WORKDIR}/sensord.cgi ${D}/www/pages/cgi-bin
35 install -d -m a=rwxs ${D}/www/pages/sensord
36}
37
38# libsensors configuration
39PACKAGES =+ "${PN}-libsensors"
40
41# sensord logging daemon configuration
42PACKAGES =+ "${PN}-sensord"
43
44# fancontrol script configuration
45PACKAGES =+ "${PN}-fancontrol"
46
47# sensord web cgi support
48PACKAGES =+ "${PN}-cgi"
49RRECOMMENDS_${PN}-cgi = "lighttpd lighttpd-module-cgi"
50RDEPENDS_${PN}-cgi = "${PN}-sensord rrdtool"
51FILES_${PN}-cgi = "/www/*"
52
53# libsensors configuration file
54FILES_${PN}-libsensors = "${sysconfdir}/sensors.d/sensors.conf"
55
56# sensord logging daemon configuration files
57FILES_${PN}-sensord = "\
58 ${sysconfdir}/sensord.conf \
59 ${sysconfdir}/sysconfig/sensord \
60"
61
62# fancontrol script configuration file
63FILES_${PN}-fancontrol = "${sysconfdir}/fancontrol"