blob: 542b2ba19a16c32d6c2ea06dbc07b53d310ae14b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git \
9 file://mcelog-debash.patch \
10 file://run-ptest \
11"
12
13SRCREV = "0fc9f702232cb2d9969916f899c67c3e64deedda"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://README;md5=3eb76ca64fa07ad53ebb0ebb5b4c8ede"
17
18S = "${WORKDIR}/git"
19
20inherit autotools-brokensep ptest
21
22COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
23
24do_install_append() {
25 install -d ${D}${sysconfdir}/cron.hourly
26 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
27 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
28}
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}
32 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
33 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
34}
35
36RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"