blob: 0f1548aa284fd8573214a38068605a540b66e96b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A minimal iconv implementation w/ support for UTF-8, ASCII, ISO-8859-1"
5HOMEPAGE = "http://tinderbox.dev.gentoo.org/portage/local/misc/mini-iconv/"
6LICENSE = "MPL-1.1"
7SECTION = "libs"
8DEPENDS = ""
9PROVIDES = "virtual/libiconv"
10LIC_FILES_CHKSUM = "file://iconv.c;beginline=1;endline=6;md5=35af9d9924327fe8a0a1fe3a2cb454c8"
11SRC_URI = "http://mirror.meleeweb.net/pub/linux/gentoo/distfiles/mini-iconv.tar.bz2"
12SRC_URI[md5sum] = "84412221e26505a2b3855d4a1cdcd0e0"
13SRC_URI[sha256sum] = "3552262bf1bcf8e859a2a3a7adfb0367af8593383e730c492e981477aac0a0d4"
14
15
16S = "${WORKDIR}/${PN}"
17
18do_install() {
19 oe_runmake install DESTDIR=${D} PREFIX=${prefix} LIB=${base_libdir}
20}