blob: 37b5fef6f6de02038c4f7759928b5abe91f48e07 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2
3DEPENDS = "lvm2 libaio readline udev"
4
5LICENSE = "LGPLv2"
6
7SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
8 file://multipathd.oe \
9 file://makefile_inc.patch \
10 file://always-use-libdevmapper.patch \
11 file://always-use-libdevmapper-kpartx.patch \
12 file://do-not-link-libmpathpersist-to-TMPDIR.patch \
13 file://0001-multipathd.service-Error-fix.patch \
14 "
15# 0.5.0
16#
17#SRCREV = "82f391e787dc02e9d9294aa391137ab424bb83c4"
18#LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
19
20# 0.5.0 + commits thru 7/18/2014
21#
22#SRCREV = "0d72f46c12207a6b7b89f5ef4f5ab5f87ed8bc90"
23#LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
24
25# 0.5.0 + commits thru 9/12/2014
26#
27# includes important systemd related structure size fix
28#
29#SRCREV = "aec68ab217fd2956443b27ceeb97dd6475267789"
30LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
31
32# 0.5.0 + commits thru 2/16/2015
33SRCREV = "770e6d0da035deaced82885939161c2b69225e10"
34
35inherit systemd
36
37
38S = "${WORKDIR}/git"
39
40PV = "0.5.0+git${@'${SRCPV}'.split('+')[-1]}"
41
42# The exact version of SYSTEMD does not matter but should be greater than 209.
43#
44EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
45 OPTFLAGS="${CFLAGS}" \
46 LIB=${base_libdir} libdir=${base_libdir}/multipath \
47 unitdir=/lib/systemd/system \
48 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
49 '
50
51do_install() {
52 oe_runmake install
53
54 # Copy a sample conf file, but do not rename it multipath.conf.
55 #
56 cp multipath.conf.defaults ${D}${sysconfdir}
57
58 # We copy an initscript, but do not start multipathd at init time.
59 #
60 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
61
62}
63
64FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
65
66# systemd and udev stuff always goes under /lib!
67#
68FILES_${PN} += "${base_libdir}/multipath \
69 /lib/systemd"
70
71PACKAGES =+ "kpartx"
72FILES_kpartx = "${base_sbindir}/kpartx \
73 /usr/lib/udev/kpartx_id \
74 "
75
76RDEPENDS_${PN} += "kpartx"