blob: de979821ca2e59379b1674f38c317f965b8f34e1 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions"
2HOMEPAGE = "http://projectne10.github.io/Ne10/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=463ac0a7d64edc2b787c4206635ca2b1"
5SECTION = "libs"
6
7SRC_URI = "git://github.com/projectNe10/Ne10.git"
8SRCREV = "a08b29d88e3c94d32b5b8f827e7fcf0bc2b34ac2"
9
10S = "${WORKDIR}/git"
11
12inherit cmake
13
14NE10_TARGET_ARCH = ""
15EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"'
16
17COMPATIBLE_MACHINE_aarch64 = "(.*)"
18COMPATIBLE_MACHINE_armv7a = "(.*)"
19
20python () {
21 if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES', True).split()):
22 d.setVar('NE10_TARGET_ARCH', 'armv7')
23 bb.debug(2, 'Building Ne10 for armv7')
24 elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES', True).split()):
25 d.setVar('NE10_TARGET_ARCH', 'aarch64')
26 bb.debug(2, 'Building Ne10 for aarch64')
27 else:
28 raise bb.parse.SkipPackage("Incompatible with archs other than armv7 and aarch64")
29}
30
31do_install() {
32 install -d ${D}${libdir}
33 install -d ${D}${includedir}
34 install -m 0644 ${S}/inc/NE10*.h ${D}${includedir}/
35 install -m 0644 ${B}/modules/libNE10.a ${D}${libdir}/
36 install -m 0755 ${B}/modules/libNE10.so.* ${D}${libdir}/
37 cp -a ${B}/modules/libNE10.so ${D}${libdir}/
38}
39
40# ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel]
41# ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel]
42INSANE_SKIP_${PN} += "textrel"