blob: 199726fd08f156c751df5591a1a28000ef9efbf7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Development package for building Applications that use numa"
2DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
3to run other programs with a specific NUMA policy and a libnuma to do \
4allocations with NUMA policy in applications."
5LICENSE = "GPL-2.0 & LGPL-2.1"
6SECTION = "apps"
7RDEPENDS_${PN} = "perl"
8
9inherit autotools-brokensep ptest
10
11LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
12
13SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
14 file://fix-null-pointer.patch \
15 file://Fix-the-test-output-format.patch \
16 file://Makefile \
17 file://run-ptest \
18 file://0001-define-run-test-target.patch \
19 "
20SRC_URI[md5sum] = "d3bc88b7ddb9f06d60898f4816ae9127"
21SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861"
22
23# ARM does not currently support NUMA
24COMPATIBLE_HOST = "^((?!arm).*)$"
25
26do_install() {
27 oe_runmake DESTDIR=${D} prefix=${D}/usr install
28 #remove the empty man2 directory
29 rm -r ${D}${mandir}/man2
30}
31
32do_compile_ptest() {
33 oe_runmake test
34}
35
36do_install_ptest() {
37 #install tests binaries
38 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
39 mynode nodemap node-parse pagesize prefered randmap realloc_test \
40 tbitmap tshared"
41
42 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
43 for i in $test_binaries; do
44 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
45 done
46
47 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
48 shmtest runltp bind_range"
49 for i in $test_scripts; do
50 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
51 done
52
53 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
54 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
55}
56
57RDEPENDS_${PN}-ptest = "bash"