blob: 2dc82a8e1b4c6d435e0ba9e3ce7107110aa34920 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ODE is an Open Source Physics Engine"
2SECTION = "libs"
3HOMEPAGE = "http://www.ode.org"
4LICENSE = "LGPLv2.1 & BSD"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=1de906ee96808d9776dd72a5f9a79a22 \
7 file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff \
8"
9# LICENSE-BSD.TXT is missing in 0.13 tarball, but COPYING still says it's dual licensed
10# and svn repo still contains LICENSE-BSD.TXT so maybe it will return in next tarball
11# file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928
12
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tar.bz2 \
15 file://configure.patch"
16SRC_URI[md5sum] = "04b32c9645c147e18caff7a597a19f84"
17SRC_URI[sha256sum] = "34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9"
18
19inherit autotools binconfig
20
21EXTRA_OECONF = "--disable-demos --enable-soname"
22
23FILES_${PN} = "${libdir}/lib*${SOLIBS}"
24
25PACKAGECONFIG ?= ""
26# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
27# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
28PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"