blob: ed8ef267c85dcd500a637dfb721b8774c91dbdf1 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Web Based Enterprise Management (WBEM) Implementation"
2DESCRIPTION = "OpenWBEM is a set of software components that help facilitate \
3deployment of the Common Information Model (CIM) and Web-Based \
4Enterprise Management (WBEM) technologies of the Distributed Management \
5Task Force (DMTF). \
6 \
7Web-Based Enterprise Management (WBEM) is a set of management and \
8Internet standard technologies developed to unify the management of \
9distributed computing environments. WBEM provides the ability for the \
10industry to deliver a well-integrated set of standards-based management \
11tools, facilitating the exchange of data across otherwise disparate \
12technologies and platforms. \
13 \
14For more information about DMTF and its technologies, visit \
15http://www.dmtf.org/standards. "
16SECTION = "System/Management"
17HOMEPAGE = "http://openwbem.sourceforge.net/"
18
19inherit autotools-brokensep pkgconfig
20
21SOURCE1="novell-openwbem-root-acl.mof"
22SOURCE2="loadmof.sh"
23SOURCE3="rmmof.sh"
24SOURCE4="openwbem-owcimomd.init"
25SOURCE5="openwbem-etc_pam.d_openwbem"
26SOURCE6="openwbem-rpmlintrc"
27
28SRC_URI = " \
29 git://github.com/kkaempf/openwbem.git \
30 file://${SOURCE1} \
31 file://${SOURCE2} \
32 file://${SOURCE3} \
33 file://${SOURCE4} \
34 file://${SOURCE5} \
35 file://${SOURCE6} \
36 file://checkserverkey \
37 file://owcimomd.service \
38"
39SRCREV = "5c688eefc1f8e35a4b1c58529aae5f114c25c2a8"
40S = "${WORKDIR}/git"
41LICENSE = "BSD-3-Clause"
42LIC_FILES_CHKSUM += "file://COPYING;md5=0504a2eb85e01aa92c9efd4125a34660"
43INSANE_SKIP_${PN} = "dev-so"
44DEPENDS += "openssl libpam bash"
45RDEPENDS_${PN} += "bash"
46EXTRA_OECONF = " \
47 --prefix=/usr \
48 --sysconfdir=/etc \
49 --libdir=${libdir} \
50 --localstatedir=/var/lib \
51 --libexecdir=${libdir}/openwbem/bin \
52 --mandir=/usr/share/man \
53 --enable-threads-run-as-user \
54"
55do_configure_prepend() {
56 autoreconf --force --install
57}
58
59do_install() {
60 oe_runmake DESTDIR=${D} install
61 install -d ${D}/etc/openwbem/openwbem.conf.d
62 install -d ${D}/var/adm/fillup-templates
63 install -m 644 etc/sysconfig/daemons/owcimomd ${D}/var/adm/fillup-templates/sysconfig.owcimomd
64
65 # fix up hardcoded paths
66 sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service
67 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
68 install -d ${D}/${systemd_unitdir}/system
69 install -m 644 ${WORKDIR}/owcimomd.service ${D}/${systemd_unitdir}/system
70 install -m 755 ${WORKDIR}/checkserverkey ${D}${sysconfdir}/openwbem/
71 fi
72
73 install -d ${D}/etc/init.d
74 ln -sf ../../etc/init.d/owcimomd ${D}/usr/sbin/rcowcimomd
75 install -m 755 ${WORKDIR}/${SOURCE4} ${D}/etc/init.d/owcimomd
76 install -d ${D}${sbindir}
77 install -d ${D}/usr/bin
78 install -d ${D}/etc/pam.d
79 install -d ${D}/${libdir}/openwbem/cmpiproviders
80 install -m 644 etc/pam.d/openwbem ${D}/etc/pam.d
81 install -d ${D}/${libdir}/openwbem/c++providers
82 install -d ${D}/var/lib/openwbem
83 install -m 755 ${WORKDIR}/${SOURCE2} ${D}/usr/bin/ow-loadmof.sh
84 install -m 755 ${WORKDIR}/${SOURCE3} ${D}/usr/bin/ow-rmmof.sh
85 install -m 644 ${WORKDIR}/${SOURCE5} ${D}/etc/pam.d/openwbem
86
87 MOFPATH=${D}/usr/share/mof/openwbem
88 install -d $MOFPATH
89 mv ${D}/usr/share/openwbem/* $MOFPATH/
90 rmdir ${D}/usr/share/openwbem
91 install -m 644 ${WORKDIR}/${SOURCE1} $MOFPATH/
92
93 touch ${D}/var/lib/openwbem/{classassociation,instances,instassociation,namespaces,schema}.{dat,ndx,lock}
94}
95
96inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
97SYSTEMD_SERVICE_${PN} = "owcimomd.service"
98SYSTEMD_AUTO_ENABLE = "disable"
99FILES_${PN} += " \
100 ${libdir} \
101 ${datadir}/mof \
102 ${systemd_unitdir} \
103"
104FILES_${PN}-dbg += " \
105 ${libdir}/openwbem/c++providers/.debug \
106 ${libdir}/openwbem/provifcs/.debug \
107 ${libdir}/openwbem/bin/openwbem/.debug \
108"
109FILES_${PN}-dev = " \
110 ${includedir} \
111 ${datadir}/aclocal/openwbem.m4 \
112"