blob: dbee656098f6a3f1a83c402d13b070f6d23617ae [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Lightweight and minimal (~20K) dumb-terminal emulation program"
2SECTION = "console/utils"
3LICENSE = "GPLv2+"
4HOMEPAGE = "http://code.google.com/p/picocom/"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=393a5ca445f6965873eca0259a17f833"
6
7SRC_URI = "http://picocom.googlecode.com/files/picocom-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "8eaba1d31407e8408674d6e57af447ef"
10SRC_URI[sha256sum] = "d0f31c8f7a215a76922d30c81a52b9a2348c89e02a84935517002b3bc2c1129e"
11
12CPPFLAGS_append = '-DVERSION_STR=\\"${PV}\\" -DUUCP_LOCK_DIR=\\"/var/lock\\" -DHIGH_BAUD'
13
14do_install () {
15 install -d ${D}${bindir}
16 install -m 0755 ${BPN} pcasc pcxm pcym pczm ${D}${bindir}/
17}
18