blob: cd4614070870dd233df1198bc534225d15766d17 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "multi-protocol instant messaging client"
2SECTION = "x11/network"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "python virtual/libintl intltool-native libxml2 gconf"
6
7inherit autotools gettext pkgconfig gconf perlnative
8
9SRC_URI = "\
10 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
11 file://sanitize-configure.ac.patch \
12 file://purple-OE-branding-25.patch \
13 file://pidgin-cross-python-265.patch \
14"
15
16SRC_URI[md5sum] = "14e0f5cfb2ed065e4dc80391a806ac76"
17SRC_URI[sha256sum] = "2c7523f0fefe89749c03b2b738ab9f7bd186da435be4762f1487eee31e77ffdd"
18
19PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
21"
22PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
23# --disable-gstreamer compile without GStreamer audio support
24# --disable-gstreamer-video
25# compile without GStreamer 1.0 Video Overlay support
26# --disable-gstreamer-interfaces
27# compile without GStreamer 0.10 interface support
28# --with-gstreamer=<version>
29# compile with GStreamer 0.10 or 1.0 interface
30PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
31PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
32PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
33PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
34PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
35PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
36PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,ncurses"
37PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls"
38PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
39PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
40
41EXTRA_OECONF = " \
42 --disable-perl \
43 --disable-tcl \
44 --disable-gevolution \
45 --disable-schemas-install \
46 --disable-gtkspell \
47 --disable-meanwhile \
48 --disable-nm \
49 --disable-screensaver \
50 --enable-nss=no \
51"
52
53do_configure_prepend() {
54 touch ${S}/po/Makefile
55 sed -i "s#PY_VERSION=`$PYTHON -c 'import sys ; print sys.version[0:3]'`#PY_VERSION=${PYTHON_BASEVERSION}#g" ${S}/configure.ac
56}
57
58OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
59OE_LT_RPATH_ALLOW[export]="1"
60
61PACKAGES =+ "libpurple-dbg libpurple-dev libpurple libgnt-dbg libgnt libgnt-dev finch-dbg finch finch-dev ${PN}-data"
62
63LEAD_SONAME = "libpurple.so.0"
64FILES_libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
65FILES_libpurple-dev = "${libdir}/libpurple*.la \
66 ${libdir}/libpurple*.so \
67 ${libdir}/purple-2/*.la \
68 ${libdir}/purple-2/libjabber.so \
69 ${libdir}/purple-2/liboscar.so \
70 ${libdir}/purple-2/libymsg.so \
71 ${datadir}/aclocal"
72FILES_libpurple-dbg += "${libdir}/.debug/libpurple* \
73 ${libdir}/purple-2/.debug"
74FILES_libgnt = "${libdir}/libgnt.so.* ${libdir}/gnt/*.so"
75FILES_libgnt-dev = "${libdir}/gnt/*.la"
76FILES_libgnt-dbg = "${libdir}/gnt/.debug"
77FILES_finch = "${bindir}/finch"
78FILES_finch-dev = "${libdir}/finch/*.la"
79FILES_finch-dbg = "${bindir}/.debug/finch \
80 ${libdir}/finch/.debug"
81
82FILES_${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
83 ${datadir}/applications"
84RRECOMMENDS_${PN} = "${PN}-data libpurple-plugin-ssl-gnutls libpurple-protocol-irc libpurple-protocol-xmpp"
85
86FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
87FILES_${PN}-dev += "${libdir}/${PN}/*.la"
88
89PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
90
91python populate_packages_prepend () {
92 pidgroot = d.expand('${libdir}/pidgin')
93 purple = d.expand('${libdir}/purple-2')
94 finch = d.expand('${libdir}/finch')
95
96 do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$',
97 output_pattern='pidgin-plugin-%s',
98 description='Pidgin plugin %s',
99 prepend=True, extra_depends='')
100
101 do_split_packages(d, purple, '^lib(.*)\.so$',
102 output_pattern='libpurple-protocol-%s',
103 description='Libpurple protocol plugin for %s',
104 prepend=True, extra_depends='')
105
106 do_split_packages(d, purple, '^(ssl-.*)\.so$',
107 output_pattern='libpurple-plugin-%s',
108 description='libpurple plugin %s',
109 prepend=True, extra_depends='libpurple-plugin-ssl')
110
111 do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$',
112 output_pattern='libpurple-plugin-%s',
113 description='libpurple plugin %s',
114 prepend=True, extra_depends='')
115
116 do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$',
117 output_pattern='finch-plugin-%s',
118 description='Finch plugin %s',
119 prepend=True, extra_depends='')
120}