blob: 082dc005ff45d6dbf63538dcefb6dfc95c9dcaad [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A user-space tool to show and modify the state of GPIOs on the S3c24xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://gpio.c;endline=12;md5=cfb91c686857b2e60852b4925d90a3e1"
6SRCREV = "4949"
7PV = "1.0+svnr${SRCPV}"
8PR = "r2"
9
10SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http"
11S = "${WORKDIR}/gpio"
12
13CLEANBROKEN = "1"
14
15do_compile() {
16 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio.c
17}
18
19do_install() {
20 install -d ${D}${sbindir}
21 install -m 0755 ${PN} ${D}${sbindir}
22}