blob: bed0555c2817cb64f62fdddee76bfdf566522f38 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A user-space tool to show and modify the state of GPIOs on the S3c64xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://gpio-s3c6410.c;endline=12;md5=060cda1be945ad9194593f11d56d55c7"
6SRCREV = "4949"
7PV = "1.0+svnr${SRCPV}"
8
9SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http"
10S = "${WORKDIR}/gpio"
11
12CLEANBROKEN = "1"
13
14do_compile() {
15 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c
16}
17
18do_install() {
19 install -d ${D}${sbindir}
20 install -m 0755 ${PN} ${D}${sbindir}
21}