blob: 7f59b3ecad17185b9b38af6a3e7fb40d335340f3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Receive a forwarded serial from serial-forward and provide a PTY"
2AUTHOR = "Holger 'Zecke' Freyther"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07"
5SECTION = "console/network"
6SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec"
7PV = "1.1+gitr${SRCPV}"
8
9SRC_URI = "git://github.com/freesmartphone/cornucopia.git;protocol=https"
10S = "${WORKDIR}/git/tools/serial_forward"
11
12inherit autotools native
13
14do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_IMAGE}"
15do_deploy() {
16 install -d ${DEPLOY_DIR_IMAGE}
17 install -m 0755 ${B}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
18}
19
20addtask deploy before do_package after do_install