blob: 5ee4472cd940ca66bbdc2572ab2c874437748933 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \
2package"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;endline=21;md5=8fbd0497a7d0b01e99820bffcb58e9ad"
5# start-stop-daemon is usually shipped by dpkg
6DEPENDS = "ncurses"
7RCONFLICTS_${PN} = "dpkg"
8
9SRC_URI = " \
10 ${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.xz \
11 file://0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch \
12"
13
14SRC_URI[md5sum] = "e48fcfdb2162e77d72c2a83432d537ca"
15SRC_URI[sha256sum] = "07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa"
16
17inherit autotools gettext pkgconfig
18
19S = "${WORKDIR}/dpkg-${PV}"
20
21EXTRA_OECONF = " \
22 --without-bz2 \
23 --without-selinux \
24"
25
26do_install_append () {
27 # remove everything that is not related to start-stop-daemon, since there
28 # is no explicit rule for only installing ssd
29 find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
30 find ${D} -depth -type d -empty -exec rmdir {} \;
31
32 # support for buggy init.d scripts that refer to an alternative
33 # explicit path to start-stop-daemon
34 mkdir -p ${D}/sbin/
35 ln -sf /usr/sbin/start-stop-daemon ${D}/sbin/start-stop-daemon
36}