blob: e6057f449ea9174dd972bcae9b865070fe150435 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Synergy - control multiple computers with one keyboard and mouse"
2HOMEPAGE = "http://synergy-project.org"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0f366945b209c5523e39889f636af00a"
4LICENSE = "GPL-2.0"
5SECTION = "x11/utils"
6
7DEPENDS = "virtual/libx11 libxtst libxinerama unzip-native curl openssl"
8
9# depends on virtual/libx11
10REQUIRED_DISTRO_FEATURES = "x11"
11
12SRC_URI = "git://github.com/synergy/synergy.git;protocol=http"
13
14# Version 1.7.4-rc8
15SRCREV ?= "588fb4b805dd452556d05dbc03fe29ea5b4e43c0"
16PV = "1.7.3+1.7.4-rc8+${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20inherit cmake distro_features_check
21
22do_unpack_extra() {
23 cd ${S}/ext
24 for file in *.zip; do
25 fname="${file##*/}"
26 unzip $file -d ${fname%.*}
27 done
28}
29addtask unpack_extra after do_unpack before do_patch
30
31do_install() {
32 install -d ${D}/usr/bin
33 install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/
34}