blob: fbbfa3dd8b200dec50380e259a84116bf622a3eb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "xorg.conf keyboard layout callout"
2DESCRIPTION = "system-setup-keyboard is a daemon to monitor the keyboard layout configured in \
3/etc/sysconfig/keyboard and transfer this into the matching xorg.conf.d snippet."
4
5HOMEPAGE = "https://git.fedorahosted.org/git/system-setup-keyboard.git"
6SECTION = "Applications/System"
7
8SRC_URI = "https://git.fedorahosted.org/cgit/${PN}.git/snapshot/${BP}.tar.gz"
9SRC_URI[md5sum] = "399003968ccc739cddd9cc370af377a0"
10SRC_URI[sha256sum] = "1ef6ef79c3588e85d7f42e99eb80a2e459f966284cf029c2d6fc1b645abcb860"
11
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://COPYING;md5=bf57969a59612c5aca007b340c49d3a2"
14
15inherit pythonnative
16
17DEPENDS = "glib-2.0 system-config-keyboard-native"
18
19EXTRA_OEMAKE = "-e MAKEFLAGS="
20
21do_compile_prepend() {
22 ${PYTHON} -v get_layouts.py > keyboards.h
23}
24
25do_install() {
26 oe_runmake install DESTDIR=${D}
27 install -d ${D}/etc/X11/xorg.conf.d
28 touch ${D}/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf
29}
30
31FILES_${PN} += "${systemd_unitdir}/system/${BPN}.service"