blob: ac8593cb67f64cd17921b3a5e2cc6950e7af1519 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "TOMOYO Linux tools"
2DESCRIPTION = "TOMOYO Linux is a Mandatory Access Control (MAC) implementation \
3for Linux that can be used to increase the security of a system, while also \
4being useful purely as a system analysis tool."
5HOMEPAGE = "http://tomoyo.sourceforge.jp/"
6SECTION = "System Environment/Kernel"
7
8SRC_URI = "http://jaist.dl.sourceforge.jp/tomoyo/53357/${BP}-20140601.tar.gz"
9SRC_URI[md5sum] = "888869b793127f00d6439a3246598b83"
10SRC_URI[sha256sum] = "118ef6ba1fbf7c0b83018c3a0d4d5485dfb9b5b7f647f37ce9f63841a3133c2a"
11
12S = "${WORKDIR}/${BPN}"
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING.tomoyo;md5=751419260aa954499f7abaabaa882bbe"
16
17FILES_${PN} += "${libdir}/tomoyo"
18FILES_${PN}-dbg += "${libdir}/tomoyo/.debug"
19
20DEPENDS = "linux-libc-headers ncurses"
21
22EXTRA_OEMAKE = "-e USRLIBDIR=${libdir}"
23
24do_compile () {
25 oe_runmake 'CC=${CC}'
26}
27
28do_install() {
29 oe_runmake install INSTALLDIR=${D}
30}