blob: 6da11cd94694989cc32c1f248f0bbde77e0b9fde [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Full-featured IRC chat client with scripting support"
2LICENSE = "GPLv2+"
3HOMEPAGE = "http://www.xchat.org"
4SECTION = "x11/network"
5
6DEPENDS = "libgcrypt zlib gtk+ libsexy"
7DEPENDS += "gdk-pixbuf-native"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
10
11PR = "r2"
12
13SRC_URI = "http://xchat.org/files/source/2.8/xchat-${PV}.tar.bz2 \
14 file://glib-2.32.patch \
15 file://automake-foreign.patch \
16 file://fix-includes-for-separate-build.patch \
17"
18
19inherit autotools gettext pkgconfig
20
21PACKAGECONFIG ??= "dbus"
22PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus-glib"
23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24PACKAGECONFIG[python] = "--enable-python,--disable-python,python"
25
26EXTRA_OECONF = "\
27 --enable-maintainer-mode \
28 --disable-perl \
29 --disable-tcl \
30"
31
32RDEPENDS_${PN} += "dbus"
33FILES_${PN} += "${datadir}/dbus-1"
34FILES_${PN}-dbg += "${libdir}/xchat/plugins/.debug"
35
36SRC_URI[md5sum] = "6775c44f38e84d06c06c336b32c4a452"
37SRC_URI[sha256sum] = "0d6d69437b5e1e45f3e66270fe369344943de8a1190e498fafa5296315a27db0"