blob: b943d6d48e630392d8323107384dfbdd9ef9fc75 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=deb8af5388e838d133eaa036f4d1496f"
7
8PV = "14.12.00"
9
10SRCREV = "efc18d16294f492b7f72bba64344b2eed50e6a69"
11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "libpcre json-c glib-2.0"
16
17inherit autotools-brokensep
18
19CFLAGS += "-I${STAGING_INCDIR}/json-c"
20
21FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
22FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
23FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
24FILES_${PN}-dbg += "${libdir}/fwts/.debug"