blob: fb4c0c45577cc7cecac8e3dee3dbe88c83eff36f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "a utility to add users/groups to the system"
2DESCRIPTION = "adduser, addgroup - add a user or group to the system"
3HOMEPAGE = "http://alioth.debian.org/projects/adduser/"
4SECTION = "base/utils"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://debian/copyright;md5=caed49ab166f22ef31bf1127f558d0ef"
8
9SRC_URI = "http://ftp.de.debian.org/debian/pool/main/a/${BPN}/${BPN}_${PV}.tar.xz \
10 file://adduser-add-M-option-for-useradd-when-no-create-home.patch \
11"
12
13SRC_URI[md5sum] = "3a079dd4e41d5a1fbaccaab03aacd881"
14SRC_URI[sha256sum] = "693b45bb0d27938fff2ecee5442ea2ac1b8804472ff0bb8faffd39616e58211f"
15
16inherit cpan-base update-alternatives
17
18S = "${WORKDIR}/${BPN}-3.113+nmu4"
19
20do_install() {
21 install -d ${D}${sbindir}
22 install -m 0755 ${S}/adduser ${D}${sbindir}
23 install -m 0755 ${S}/deluser ${D}${sbindir}
24
25 install -d ${D}${libdir}/perl/${PERLVERSION}/Debian
26 install -m 0644 ${S}/AdduserCommon.pm ${D}${libdir}/perl/${PERLVERSION}/Debian
27 sed -i -e "s/VERSION/${PV}/" ${D}${sbindir}/*
28
29 install -d ${D}/${sysconfdir}
30 install -m 0644 ${S}/*.conf ${D}/${sysconfdir}
31
32 install -d ${D}${mandir}/man5
33 install -m 0644 ${S}/doc/*.conf.5 ${D}${mandir}/man5
34 install -d ${D}${mandir}/man8
35 install -m 0644 ${S}/doc/*.8 ${D}${mandir}/man8
36 install -d ${D}${docdir}/${BPN}
37 cp -rf ${S}/examples ${D}${docdir}/${BPN}
38}
39
40RDEPENDS_${PN} += "\
41 shadow \
42 perl-module-getopt-long \
43 perl-module-overloading \
44 perl-module-file-find \
45 perl-module-file-temp \
46"
47
48ALTERNATIVE_${PN} = "adduser deluser addgroup delgroup"
49ALTERNATIVE_PRIORITY = "60"
50ALTERNATIVE_LINK_NAME[adduser] = "${sbindir}/adduser"
51ALTERNATIVE_LINK_NAME[deluser] = "${sbindir}/deluser"
52ALTERNATIVE_LINK_NAME[addgroup] = "${sbindir}/addgroup"
53ALTERNATIVE_LINK_NAME[delgroup] = "${sbindir}/delgroup"
54ALTERNATIVE_TARGET[addgroup] = "${sbindir}/adduser.${BPN}"
55ALTERNATIVE_TARGET[delgroup] = "${sbindir}/deluser.${BPN}"