blob: e7e9d9128c9e0dc29da8fdc12ecc047293eef6e2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "lib-curses provides an interface between Perl programs and \
2the curses library."
3
4SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0+"
6
7LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
8
9DEPENDS += "perl ncurses "
10
11SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "874c2103cc53552a0faa371c4d9119f6"
14SRC_URI[sha256sum] = "808e44d5946be265af5ff0b90f3d0802108e7d1b39b0fe68a4a446fe284d322b"
15
16S = "${WORKDIR}/Curses-${PV}"
17
18EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}"
19
20inherit cpan
21
22do_compile() {
23 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
24 cpan_do_compile
25}
26