blob: 68bfd66fb7a8d55d98755458af90935b4a17ccfe [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A Perl DBI driver for SQLite"
2DESCRIPTION = "DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire \
3thing in the distribution. So in order to get a fast transaction capable \
4RDBMS working for your perl project you simply have to install this \
5module, and nothing else. \
6"
7HOMEPAGE = "http://search.cpan.org/~ishigaki/DBD-SQLite/"
8
9SECTION = "libs"
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11DEPENDS += "libdbi-perl-native"
12RDEPENDS_${PN} += "libdbi-perl \
13 sqlite3 \
14 perl-module-constant \
15 perl-module-locale \
16 perl-module-tie-hash \
17"
18
19LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360"
20
21SRC_URI = "http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \
22 file://sqlite-perl-test.pl \
23"
24
25SRC_URI[md5sum] = "d56eebfb5f2a14be9413b025e7dca9fe"
26SRC_URI[sha256sum] = "3ac513ab73944fd7d4b672e1fe885dc522b6369d38f46a68e67e0045bf159ce1"
27
28S = "${WORKDIR}/DBD-SQLite-${PV}"
29
30inherit cpan
31
32BBCLASSEXTEND = "native"
33
34do_install_append() {
35 if [ ${PERL_DBM_TEST} = "1" ]; then
36 install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl
37 fi
38}
39