blob: 0238781cbcd0812001f6737ba4675698e553fcaf [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10RDEPENDS_${PN} = " perl-module-carp \
11 perl-module-exporter \
12 perl-module-exporter-heavy \
13 perl-module-dynaloader \
14"
15
16LIC_FILES_CHKSUM = "file://DBI.pm;beginline=8147;endline=8151;md5=d4e73f2616b2b41334cf2f7d25d827a2"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
19SRC_URI[md5sum] = "4ad15a9c2cc9b68e3fe1f5cadf9cdb30"
20SRC_URI[sha256sum] = "250712f385864818abfba409420d16d9ee61f1cc73ac85159d054a5ee86d1450"
21
22S = "${WORKDIR}/DBI-${PV}"
23
24inherit cpan
25
26BBCLASSEXTEND = "native"