blob: d13cb03ee92bb8848b24ebb0735f67b99043df18 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
2DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
3compiler that is compatible with the C compiler that your perl was built \
4with. \
5It can generate the necessary options to the Module::Build constructor or \
6to ExtUtils::MakeMaker's WriteMakefile function."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
10
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
15SRC_URI[md5sum] = "f8ada38ee4ad86a4f1e20d8525ce0c99"
16SRC_URI[sha256sum] = "48625195a88c0f2ddc37bbd7a06346aa68ffb6948ba78da3aea47c0db2540f65"
17
18S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
19
20inherit cpan
21
22do_install () {
23 cpan_do_install
24}
25
26RDEPENDS_${PN} = " libcapture-tiny-perl \
27 perl-module-scalar-util \
28 perl-module-io-file \
29 perl-module-extutils-makemaker \
30 perl-module-file-spec \
31 perl-module-exporter \
32 perl-module-carp \
33 perl-module-file-temp \
34 perl-module-lib \
35"
36
37BBCLASSEXTEND = "native"