blob: 1566f75be572b8fab419d00f6f7461825e8a09f4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ExtUtils::ParseXS - converts Perl XS code into C code"
2DESCRIPTION = "\"ExtUtils::ParseXS\" will compile XS code into C code by \
3embedding the constructs necessary to let C functions manipulate Perl \
4values and creates the glue necessary to let Perl access those functions. \
5The compiler uses typesmapes to determine how to map C function parameters \
6and variables to Perl values."
7
8SECTION = "libs"
9
10HOMEPAGE = "http://metapan.org/release/ExtUtils-ParseXS/"
11
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13LIC_FILES_CHKSUM = "file://README;beginline=121;endline=130;md5=10ddb3a673b4c732022ac899968ea9cc"
14
15SRCNAME = "ExtUtils-ParseXS"
16SRC_URI = "${CPAN_MIRROR}/authors/id/S/SM/SMUELLER/${SRCNAME}-${PV}.tar.gz"
17SRC_URI[md5sum] = "e6be3f1d493e04ed805576104cf4328b"
18SRC_URI[sha256sum] = "30b60b8208fc9b7746ed934b678bb9618a8f28994dae8774548353a7b550371e"
19
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit cpan
23
24RDEPENDS_${PN} = " perl-module-carp \
25 perl-module-cwd \
26 perl-module-dynaloader \
27 perl-module-extutils-cbuilder \
28 perl-module-extutils-makemaker \
29 perl-module-file-basename \
30 perl-module-file-spec \
31 perl-module-lib \
32 perl-module-symbol \
33 perl-module-test-more \
34"
35
36RPROVIDES_${PN} += " libextutils-parsexs-constants-perl \
37 libextutils-parsexs-countlines-perl \
38 libextutils-parsexs-eval-perl \
39 libextutils-parsexs-utilities-perl \
40 libextutils-typemaps-perl \
41 libextutils-typemaps-cmd-perl \
42 libextutils-typemaps-inputmap-perl \
43 libextutils-typemaps-outputmap-perl \
44 libextutils-typemaps-type-perl \
45"
46
47BBCLASSEXTEND = "native"