blob: 76cac5089ab14d78483d528f54faa490eed68c7c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Automatically give your module the ability to have plugins"
2DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
3having 'plugins' for your module. Obviously this isn't going to be the \
4be all and end all of solutions but it works for me.\
5\
6Essentially all it does is export a method into your namespace that \
7looks through a search path for .pm files and turn those into class \
8names.\
9\
10Optionally it instantiates those classes for you."
11SECTION = "libs"
12
13AUTHOR = "Simon Wistow <simon@thegestalt.org>"
14HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
15
16LICENSE = "Artistic-1.0 | GPL-1.0+"
17LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
18
19SRCNAME = "Module-Pluggable"
20SRC_URI = "https://github.com/moto-timo/${SRCNAME}/archive/${PV}.tar.gz"
21SRC_URI[md5sum] = "e32475d6ff5843f738cedacd3b7a2cdb"
22SRC_URI[sha256sum] = "58c62292eea6d06959eba1b97598650813211265403242d57efb2f605c96059f"
23
24S = "${WORKDIR}/${SRCNAME}-${PV}"
25
26inherit cpan
27
28RDEPENDS_${PN} = " perl-module-base \
29 perl-module-deprecate \
30 perl-module-file-basename \
31 perl-module-file-find \
32 perl-module-file-spec \
33 perl-module-file-spec-functions \
34 perl-module-if \
35 perl-module-test-more \
36"
37
38BBCLASSEXTEND = "native"
39