blob: b92842c463a1b948b17a55d5f809885ef4fd89c9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Module::Runtime - runtime module handling"
2DESCRIPTION = "The functions exported by this module deal with runtime \
3handling of Perl modules, which are normally handled at compile time. This \
4module avoids using any other modules, so that it can be used in low-level \
5infrastructure. \
6The parts of this module that work with module names apply the same syntax \
7that is used for barewords in Perl source. In principle this syntax can vary \
8between versions of Perl, and this module applies the syntax of the Perl on \
9which it is running. In practice the usable syntax hasn't changed yet, but \
10there's a good chance of it changing in Perl 5.18. \
11The functions of this module whose purpose is to load modules include \
12workarounds for three old Perl core bugs regarding require. These workarounds \
13are applied on any Perl version where the bugs exist, except for a case where \
14one of the bugs cannot be adequately worked around in pure Perl."
15SECTION = "libs"
16
17HOMEPAGE = "http://search.cpan.org/~zefram/Module-Runtime/"
18
19LICENSE = "Artistic-1.0 | GPL-1.0+"
20LIC_FILES_CHKSUM = "file://README;beginline=45;endline=46;md5=62e24a93342fede7221d66335c716f34"
21
22SRCNAME = "module-runtime"
23SRC_URI = "https://github.com/moto-timo/${SRCNAME}/archive/${PV}.tar.gz"
24SRC_URI[md5sum] = "ad6ca179c978aa02ac8aa29244ef9beb"
25SRC_URI[sha256sum] = "59effa82b3f6986d28de6154a8f2428157691004d951f936a81e851f4dbcb045"
26
27S = "${WORKDIR}/${SRCNAME}-${PV}"
28
29inherit cpan
30
31RDEPENDS_${PN} = " perl-module-test-more \
32 perl-module-strict \
33"
34
35BBCLASSEXTEND = "native"