blob: a2a1305748ad6ebf9a57b6cc70d6357cbfbc66c9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Sub::Exporter::Progressive - Only use Sub::Exporter if you need it."
2DESCRIPTION = "\"Sub::Exporter\" is an incredibly powerful module, but with \
3that power comes great responsibility, er- as well as some runtime penalties. \
4This module is a \"Sub::Exporter\" wrapper that will let your users just use \
5\"Exporter\" if all they are doing is picking exports, but use \
6\"Sub::Exporter\" if your users try to use \"Sub::Exporter's\" more advanced \
7features, like renaming exports, if they try to use them."
8
9SECTION = "libs"
10
11HOMEPAGE = "https://metacpan.org/pod/Sub-Exporter-Progressive/"
12
13LICENSE = "Artistic-1.0 | GPL-1.0+"
14LIC_FILES_CHKSUM = "file://README;beginline=51;endline=53;md5=a171d2e9f8688a44e5f1b6dcc62029e6"
15
16DEPENDS_${PN} = " perl-module-test-more"
17
18SRC_URI = "${CPAN_MIRROR}/authors/id/F/FR/FREW/Sub-Exporter-Progressive-${PV}.tar.gz"
19SRC_URI[md5sum] = "bb50b3ba1538902b197c04818a84230a"
20SRC_URI[sha256sum] = "0618c6e69c6c0540c41e7560d51981407a6a0768f1330bef6d6ac3c6f1fa7c06"
21
22S = "${WORKDIR}/Sub-Exporter-Progressive-${PV}"
23
24inherit cpan
25
26RDEPENDS_${PN} += " perl-module-carp \
27 perl-module-list-util \
28"
29
30BBCLASSEXTEND = "native"