blob: 5ff753eda669800dd937e2dbc8f5b89c93c5da68 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
5
6PV = "1.2+git${SRCPV}"
7SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
8SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
9 file://gateone-avahi.service \
10 file://80oe.conf.in \
11 file://gateone.service.in \
12 file://gateone-init.in \
13"
14
15S = "${WORKDIR}/git"
16
17inherit distutils python-dir systemd update-rc.d
18export prefix = "${localstatedir}"
19
20DISTUTILS_INSTALL_ARGS = "--root=${D} \
21 --prefix=${prefix} \
22 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
23 --install-data=${PYTHON_SITEPACKAGES_DIR} \
24 --install-scripts=${bindir} \
25 --skip_init_scripts"
26
27do_install_append() {
28
29 # fix up hardcoded paths
30 for file in gateone.service gateone-init 80oe.conf; do
31 sed -e s:@bindir@:${bindir}:g \
32 -e s:@localstate@:${localstatedir}:g \
33 < ${WORKDIR}/$file.in \
34 > ${WORKDIR}/$file
35 done
36
37 install -d ${D}${systemd_unitdir}/system
38 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
39
40 install -d ${D}${sysconfdir}/init.d
41 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
42
43 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
44 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
45
46 install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
47 install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
48
49 install -d ${D}${localstatedir}/lib/gateone
50}
51
52FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
53RDEPENDS_${PN} = "mime-support \
54 openssh-ssh \
55 python-compression \
56 python-contextlib \
57 python-crypt \
58 python-datetime \
59 python-email \
60 python-fcntl \
61 python-futures \
62 python-html \
63 python-imaging \
64 python-io \
65 python-json \
66 python-logging \
67 python-misc \
68 python-multiprocessing \
69 python-netclient \
70 python-pkgutil \
71 python-pyopenssl \
72 python-re \
73 python-readline \
74 python-setuptools \
75 python-shell \
76 python-simplejson \
77 python-subprocess \
78 python-syslog \
79 python-terminal \
80 python-textutils \
81 python-tornado \
82 python-unixadmin \
83 python-xml \
84 python-html5lib \
85 bash \
86"
87
88SYSTEMD_SERVICE_${PN} = "gateone.service"
89INITSCRIPT_NAME = "gateone"