blob: 120a8a79279202a1317d8cda2e77fe48f07c18f1 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "A component which enables calling DBus methods and registering on DBus signals from Javascript"
2HOMEPAGE = "https://github.com/01org/cloudeebus"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
6
7SRC_URI = "git://github.com/01org/cloudeebus.git;protocol=http;branch=master "
8SRCREV = "b5cc957eeabfe98cb996baf8e5a0ac848993c3d4"
9
10S = "${WORKDIR}/git"
11
12inherit distutils
13
14DEPENDS_${PN} = "python python-distribute"
15RDEPENDS_${PN} = "python python-dbus python-json python-argparse python-pygobject python-autobahn python-twisted python-subprocess"
16
17do_install_prepend() {
18 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}
19}
20
21DISTUTILS_INSTALL_ARGS = "--root=${D} \
22 --single-version-externally-managed \
23 --prefix=${prefix} \
24 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
25 --install-data=${datadir}"
26
27do_install_append() {
28 distutils_do_install
29 install -d ${D}${datadir}/doc/${BPN}/
30 install -m 0644 ${S}/README.md ${D}${datadir}/doc/${BPN}/
31}
32
33FILES_${PN} += "${datadir}/cloudeebus"
34FILES_${PN} += "${sysconfdir}/dbus-1/system.d/org.cloudeebus.conf"
35