blob: 665a4cb12332749c7f9d61308ae8e51809e22839 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
2LICENSE = "Apache-2.0 | BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
4DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
5SRCNAME = "cryptography"
6
7SRC_URI = "file://run-ptest \
8 file://build_fix_openssl_1.0.1g.patch \
9 file://Remove_SSLv2_bindings.patch \
10 file://Comment_lingering_SSLv2_symbol.patch"
11
12SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f"
13SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d"
14
15inherit pypi setuptools
16
17RDEPENDS_${PN} = "\
18 python-pyasn1\
19 python-six\
20 python-cffi\
21 python-enum34\
22 python-setuptools\
23 python-pycparser\
24 python-subprocess\
25 python-threading\
26 python-numbers\
27 python-contextlib\
28 python-ipaddress\
29 python-pyasn1\
30 python-idna\
31"
32
33RDEPENDS_${PN}-ptest = "\
34 ${PN}\
35 python-pytest\
36 python-pretend\
37 python-iso8601\
38 python-cryptography-vectors\
39"
40
41inherit ptest
42
43do_install_ptest() {
44 install -d ${D}${PTEST_PATH}/tests
45 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
46 install -d ${D}${PTEST_PATH}/tests/hazmat
47 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
48}
49
50FILES_${PN}-dbg += " \
51 ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
52 "