blob: 5027c6dbcf0987f903ad5a74b6af34bf01c42edf [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Simple Python wrapper around the OpenSSL library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5DEPENDS = "openssl python-cryptography"
6PE = "1"
7
8SRC_URI[md5sum] = "f447644afcbd5f0a1f47350fec63a4c6"
9SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984bc0d672"
10
11PYPI_PACKAGE = "pyOpenSSL"
12inherit pypi setuptools
13
14PACKAGES =+ "${PN}-tests"
15FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
16
17RDEPENDS_${PN} = "python-threading python-six python-cryptography"
18RDEPENDS_${PN}-tests = "${PN}"