blob: 43c6cecfd92f82bb8dbe6c09fddb9abfdc616425 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A pure Python netlink and Linux network configuration library"
2LICENSE = "GPLv2 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.Apache.v2;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRC_URI[md5sum] = "1e7e771702056e61cf522cccc39ea09e"
7SRC_URI[sha256sum] = "aed742a7dbe55eb7f02dbb26719f554b9e92198c4b3c7ac501ad03bbb6421962"
8
9SRC_URI += "file://import-simplejson-as-json.patch"
10
11inherit pypi setuptools
12
13RDEPENDS_${PN} += "\
14 python-distutils \
15 python-simplejson \
16 python-multiprocessing \
17 python-io python-pprint \
18 python-pickle \
19 python-logging \
20 python-threading \
21 python-textutils \
22 python-subprocess \
23 python-netclient \
24"